首页 股票学校 股票入门 选股 买入 看盘 跟庄 短线 炒股技巧 技术指标 k线图 MACD 均线 成交量 股票书籍 股票视频 网站导航

767股票学习网 > 股票书籍 > 怎样编写大智慧指标公式 > 正文

交易系统

二、 交易系统    交易系统是大智慧在条件选股功能上的一个大的延伸,旨在建立一套完整的交易规则体系,系统可以通过此平台对我们的买入、卖出等操作发出明确的买卖信号指示。 1、 编辑交易系统公式进入大智慧“公式编辑器” (1) 、点击“交易系统”选项,选择“新建”,可以建立一个亲的交易系统。(2) 、选中一个具体的交易系统,双击名称或者点击“修改”,可能浏览并编辑该系统的公式内容。 2、 交易提示编辑时常用的函数:(1)、前提:交易系统一共包含多头买入(卖出)、空头买入(卖出)四种情况,但是由于我们只允许多头买入、卖出,故我们这里不讨论空头情况。(2)、函数   ENTERLONG:多头买入函数。   EXITLONG:多头卖出函数。   简单的交易系统模型应该如下表示:   ENTERLONG:条件A; EXITLONG:条件B; 注意:一个完整的交易系统必须有进出两个条件组成,也就是说是ENTERLONG、EXITLONG或者ENTERSHORT、EXITSHORT(空头买入、卖出函数)中其中一组组成。 3、 交易系统的编制方法     首先,要确定的是,交易系统是多个条件的组合。通过不同条件的叠加、修正,系统自动在满足我们组合条件的个股K线图中添加买卖信号。 (1)、均线交易系统    如果个股5日均线上穿20日均线时,我要买入;相反,个股5日均线下穿20日均线我就卖出,这样的一个思路我们怎么来编写交易系统呢?    很简单    5日均线上穿20日均线(买入条件):CROSS(MA(CLOSE,5),MA(CLOSE,20)) 5日均线下穿20日均线(卖出条件):CROSS(MA(CLOSE,20),MA(CLOSE,5)) 按照前面所讲,交易系统函数“ENTERLONG:条件A;EXITLONG:条件B;”的方式表达:    ENTERLONG: CROSS(MA(CLOSE,5),MA(CLOSE,20)); EXITLONG: CROSS(MA(CLOSE,20),MA(CLOSE,5)); 同时按照自己的需求选择正确的介入点,如果不作选择,系统将默认在满足条件时发出提示信号。    为了方便修改指标参数,也可以将5日均线、20日均线设定成参数:SHORT和LONG,并将其默认为5、20。参数自述中加上“短期(Parsm#1)均线上穿长期(Param#2)均线买入,长期均线上穿短期均线卖出。”     那么在使用该交易系统时,用鼠标右健点击发出的买卖提示点,选择“调整指标参数”,就可以很方便的修改里面的2条均线参数。 

(2)、KDJ交易系统    我们知道如果在D 小于20的区域发生了K线上穿过D线是很好的买入条件;相反,D>80并且好生了D线下穿过了K线,则是很好的卖出条件。如何编辑呢?    第一步:在公式编写栏中分别设定公式的名称、分析周期、参数的各项内容,并编写KD的表达式,并且将K、D表达为两个中间表达式。中间表达式用符号“:=”     RSB:=(CLOSE-LLV(LOW,N))/(HHV(HIGN,N)-LLV(LOW,N)0*100; K:=SMA(RSV,M1,1); D:=SMA(K,M2,1); 第二步:完成交易系统的结构    ENTERLONG:CROSS(K,D) AND K<20; EXITLONG:CROSS(D,K) AND K>80; 完整表达式:    RSB:=(CLOSE-LLV(LOW,N))/(HHV(HIGN,N)-LLV(LOW,N)0*100; K:=SMA(RSV,M1,1); D:=SMA(K,M2,1);     ENTERLONG:CROSS(K,D) AND K<20; EXITLONG:CROSS(D,K) AND K>80;     但是,假设在一个KD强势的市场中,如果股价从下方穿过了30日均线,并且当天的成交量有比较明显的放大,我会买入;我的卖出条件是股价跌下10日均线之下立即抛出。这个交易系统怎么编辑呢?  买入条件:    KDJ强势:    AA:=”KDJ,D”(9,3,3);(因为KDJ指标中3个参数默认值分别为9、3、3,故我们应在指标中增加默认值)。    A1:=AA>40; 成交量明显放大,量化为大于5日均量的一倍。    A2:=VOL/MA(VOL,5)>2; 股价从下方上穿过了30日均线。    A3:=CROSS(CLOSE,MA(CLOSE,30)); 完整的买入条件为    ENTERLONG:A1 AND A2 AND A3; 卖出条件:  股价从上方下穿过了5日均线  A4:=CROSS(MA(CLOSE,5),CLOSE); EXITLONG:A4 AND COUNT(A1 AND A2 AND A3,20)=1; 注意其后的COUNT( )是用来限定卖出信号发生在买入条件发生的20天内。  那么,完整的公式为:  AA:=”KDJ,D”(9,3,3);   A1:=AA>40;   A2:=VOL/MA(VOL,5)>2;   A3:=CROSS(CLOSE,MA(CLOSE,30));   A4:=CROSS(MA(CLOSE,5),CLOSE);     ENTERLONG:A1 AND A2 AND A3;     EXITLONG:A4 AND COUNT(A1 AND A2 AND A3,20)=1;

上一篇文章:

下一篇文章:

 





767股票学习网 | 手机版 | 微信 | 微博 | 联系站长