首页 股票学校 股票入门 选股 买入 看盘 跟庄 短线 炒股技巧 技术指标 k线图 MACD 均线 成交量 股票书籍 股票视频 网站导航

767股票学习网 > 股票学校 > 大智慧公式 > 正文

大智慧、飞狐公式:安心操作--老鸭回头

【老鸭回头】-- 主副图(原码)
现仅以唐能通《短线是银》一书提供的理念,精心编写适应牛市行情的{老鸭回头}精品指标,作为一品的一份礼物,奉献给有缘的朋友!
指标编写思路与信号含义:1、老鸭回头=中线趋势向上+短线回头;2、坑=短线超
跌,白色特别超跌;3、买=中线趋势向上+均线粘合+短线回升;4、优选=买+10日、20日均线通道保持向上通畅;5、逃顶=短线卖点,中线只做参考;
指标使用方法:老鸭回头要关注,敢买深坑是高手;均线拐点是买点,通道顺畅应优选。
{老鸭回头Z---大智慧主图}{飞狐通用}
{N:1,20,10;}
MA5:MA(C,5),COLORWHITE;
MA10:MA(C,10),COLORFF00FF;
MA20:MA(C,20),COLOR00FF00;
MA30:MA(C,30),COLORYELLOW;
MA120:SMA(C,120,1),COLOR0000FF;
ZH520:=ABS(MA5-MA20)/MA20*100<=N;
ZH530:=ABS(MA5-MA30)/MA30*100<=N;
QSXS1:=MA5>REF(MA5,1);
QSXS2:=MA20>REF(MA20,1);
QSXS3:=MA30>REF(MA30,1);
DTPL:=MA20>MA30 AND MA30>MA120;
LYHT:=DTPL AND QSXS2 AND QSXS3 AND NOT(QSXS1) AND REF(QSXS1,1);
老鸭回头:LYHT*50,COLORFF00FF,POINTDOT,LINETHICK0;
WR5:=100*(HHV(H,5)-C)/(HHV(H,5)-LLV(L,5));
WR6:=100*(HHV(H,6)-C)/(HHV(H,6)-LLV(L,6));
WR:=80-(WR5*3+WR6*2)/5,COLORYELLOW,POINTDOT;
坑:IF(WR<0,WR,0),COLORYELLOW,POINTDOT,LINETHICK0;
LYT:=DTPL AND QSXS2 AND QSXS3 AND COUNT(QSXS1,4)<=1;
GJHS:=C>MA5 AND ((QSXS1 AND NOT(REF(QSXS1,1))) OR C>REF(C,3));
LYKK:=GJHS AND (ZH520 OR ZH530) AND LYT;
买:(LYKK AND NOT(REF(LYKK,1)))*50,COLOR00FF00,POINTDOT,LINETHICK0;
优选:(买 AND COUNT((MA10>MA20),5)=5)*100,COLORYELLOW,POINTDOT,LINETHICK0;
{以下设置主图显示方式}
DRAWTEXT(老鸭回头,(MA10+MA20)/2, '●'),COLORFF00FF;
DRAWTEXT(老鸭回头,(MA10+MA20)/2, '¤'),COLORFF00FF;
DRAWTEXT(WR<0,L*0.99, '#'),COLORYELLOW;
DRAWTEXT(WR<-10,L*0.99, '#'),COLORWHITE;
STICKLINE(买,h,l,0,1),COLOR00FF00,linethick2;
STICKLINE(买,o,c,4,1),COLOR00FF00,linethick2;
DRAWTEXT(买,L*0.99, '买★买'),COLOR00FF00;
DRAWICON(优选,L*0.99,1);
{以下设置逃顶指标}
varC:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,varC),HIGH,2);
var6:=REF(C,1);
var7:=SMA(MAX(C-var6,0),6,1)/SMA(ABS(C-var6),6,1)*100;
DRAWTEXT(CROSS(84,var7),H*1.01,'逃顶'),COLORYELLOW ;
{老鸭回头----创幻论坛一品茶缘编写精品指标!大智慧副图}{飞狐通用}
{N:1,20,10;}
MA5:=MA(C,5),COLORWHITE;
MA10:=MA(C,10),COLORFF00FF;
MA20:=MA(C,20),COLOR00FF00;
MA30:=MA(C,30),COLORYELLOW;
MA120:=SMA(C,120,1),COLOR0000FF;
ZH520:=ABS(MA5-MA20)/MA20*100<=N;
ZH530:=ABS(MA5-MA30)/MA30*100<=N;
QSXS1:=MA5>REF(MA5,1);
QSXS2:=MA20>REF(MA20,1);
QSXS3:=MA30>REF(MA30,1);
DTPL:=MA20>MA30 AND MA30>MA120;
LYHT:=DTPL AND QSXS2 AND QSXS3 AND NOT(QSXS1) AND REF(QSXS1,1);
老鸭回头:LYHT*50,COLORFF00FF;
WR5:=100*(HHV(H,5)-C)/(HHV(H,5)-LLV(L,5));
WR6:=100*(HHV(H,6)-C)/(HHV(H,6)-LLV(L,6));
WR:=80-(WR5*3+WR6*2)/5;
坑:IF(WR<0,WR,0),COLORYELLOW;
LYT:=DTPL AND QSXS2 AND QSXS3 AND COUNT(QSXS1,4)<=1;
GJHS:=C>MA5 AND ((QSXS1 AND NOT(REF(QSXS1,1))) OR C>REF(C,3));
LYKK:=GJHS AND (ZH520 OR ZH530) AND LYT;
买:(LYKK AND NOT(REF(LYKK,1)))*50,COLOR00FF00,LINETHICK2;
优选:(买 AND COUNT((MA10>MA20),5)=5)*100,COLORYELLOW,LINETHICK2;
{以下设置副图显示方式}
DRAWTEXT(老鸭回头,10,'●'),COLORFF00FF;
DRAWTEXT(老鸭回头,10,'¤'),COLORFF00FF;
STICKLINE(WR<0,WR,0,2,0),COLORYELLOW;
STICKLINE(WR<-10,WR,-10,2,0),COLORWHITE;
DRAWTEXT(买,80,'买★买'),COLOR00FF00;
DRAWICON(优选,10,1);
{以下设置逃顶指标}
varC:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,varC),80,2);
var6:=REF(C,1);
var7:=SMA(MAX(C-var6,0),6,1)/SMA(ABS(C-var6),6,1)*100;
DRAWTEXT(CROSS(84,var7),100,'逃顶'),COLORYELLOW ;
一品特别提醒:主图加入飞狐中压缩的太厉害----问题已经解决,原码飞狐直接可用.  

上一篇文章:

下一篇文章:

 




767股票学习网 | 手机版 | 微信 | 微博 | 联系站长