首页 股票学校 股票入门 选股 买入 看盘 跟庄 短线 炒股技巧 技术指标 k线图 MACD 均线 成交量 股票书籍 股票视频 网站导航

767股票学习网 > 股票学校 > 大智慧公式 > 正文

大智慧主图公式: 招招绝 原码

A3 :(EMA(CLOSE,5)+MA(CLOSE,10)+MA(CLOSE,15))/3,colorff00ff;
a4 :(EMA(CLOSE,20)+MA(CLOSE,25)+MA(CLOSE,30))/3,color00ff00;
A5 :(EMA(CLOSE,40)+MA(CLOSE,50)+MA(CLOSE,60))/3,coloryellow;
a6 :(EMA(CLOSE,80)+MA(CLOSE,85)+MA(CLOSE,90))/3,colorff9900;
A7 :(EMA(CLOSE,120)+MA(CLOSE,130)+MA(CLOSE,150))/3,color0000ff;
a8 :(EMA(CLOSE,160)+MA(CLOSE,170)+MA(CLOSE,180))/3,coloryellow;
A9 :(EMA(CLOSE,200)+MA(CLOSE,225)+MA(CLOSE,250))/3,color00ff00;
V1:EMA(CLOSE,5),Color00FFFF;
V2:EMA((EMA(CLOSE,29))*(1.01),10),ColorFF00FF;
DRAWICON(CROSS(V1,V2),V2,1),Color00FF00;
V3:EMA(CLOSE,10),ColorFFFFFF;
V4:EMA((EMA(CLOSE,60))*(0.99),10),ColorFFFF00;
DRAWICON(CROSS(V3,V4),V2,1),Color0000FF;
VF1:=MA(CLOSE,60)-MA(CLOSE,5)/3.2;
DRAWTEXT(IF(CLOSE<VF1 AND VOL/240>MA(VOL,5)/240 AND CLOSE>=REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW,'☆'),colorred;
VarA:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
VarB:=EMA(0.667*REF(VarA,1)+0.333*VarA,5);
DRAWTEXT(IF(VOL>=1.3*MA(VOL,5) AND COUNT(VarA>=VarB and VarA<-17,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW,'★注意买入');
Varr1:=SMA(MAX(CLOSE-ref(c,1),0),12,1)/SMA(ABS(CLOSE-ref(c,1)),15,1)*100;
DRAWICON(CROSS(82,Varr1),HIGH,2);
DRAWTEXT(CROSS(82,Varr1),high,'快卖↓'),coloryellow;
Var1:=(HIGH+LOW+OPEN+2*CLOSE)/5;
Var2:=REF(Var1,1);
Var3:=SMA(MAX(Var1-Var2,0),10,1)/SMA(ABS(Var1-Var2),10,1)*100;
HY3:=IF(COUNT(Var3<20,5)>=1 AND COUNT(Var1=LLV(Var1,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0);
DRAWTEXT(hy3,low,'▲买入'),colorred;


夺宝:

Var1:=EMA(C,3);
Var2:=EMA(C,5);
Var3:=EMA(C,10);
Var4:=EMA(C,20);
Var5:=EMA(C,30);
Var6:=(Var2+Var3+Var4+Var5)/4;
Var7:=(Var6-REF(Var6,15))/REF(Var6,15)*100;
Var8:=(Var6-REF(Var6,15))/REF(Var6, 15)*100;
Var9:=EMA(Var7,8);
STICKLINE(Var7<1*REF(Var7,1),h,l,0.5,0),COLORBLUE;{蓝-持币}
STICKLINE(Var7<1*REF(Var7,1),o,c,5,  1),COLORBLUE;
STICKLINE(Var7>1*REF(Var7,1),h,l,0.5,0),COLORRED;{红-持股}
STICKLINE(Var7>1*REF(Var7,1),o,c,5,  1),COLORRED;
STICKLINE(Var7<1*REF(Var7,1) AND Var9>1*REF(Var9,1),h,l,0.5,0),COLORGREEN;{绿-洗盘}
STICKLINE(Var7<1*REF(Var7,1) AND Var9>1*REF(Var9,1),o,c,5,  1),COLORGREEN;
买进价:=((c-ref(ma(c,6),1))/6+ma(c,6))*1.004;
买进条件:=cross(c,买进价) and 买进价>ref(买进价,1);
STICKLINE(买进条件,h,l,0.5,1),colorwhite,linethick2;{白-买进}
STICKLINE(买进条件,o,c,6,0),colorwhite,linethick2;
加码价:=((c-ref(ma(c,18),1))/18+ma(c,18))*1.004;
加码条件:=cross(c,加码价) and 加码价>ref(加码价,1);
STICKLINE(加码条件,h,l,0.5,1),coloryellow,linethick2;{黄-加码}
STICKLINE(加码条件,o,c,6,0),coloryellow,linethick2;
X1:EMA(C,7),color0088ff;
X2:EMA(c,21),coloree00ee;
X3:EMA(X2,21),colorwhite;
x4:ema(x3,27),color009900;
x5:ema(x2,100),colorFFAA00;
x6:ema(x5,100),color009999;
v1:ema(close,5);
v2:ema(ema(close,29)*1.01,10);
DRAWICON(cross(v1,v2),v2,1);                                    LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
逃 :if(CROSS(84,RSI) , HIGH,high+1),pointdot,linethick7,COLORYELLOW ;high+1,pointdot,linethick7,COLOR000000;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
DRAWICON(FILTER(B1>0,5),L*0.94,10);
DRAWTEXT(FILTER(B1>0,5),L*0.94,'M底'),COLORGREEN;{MACD底背离}
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
DRAWICON(FILTER(B2>0,5),L*0.96,10);
DRAWTEXT(FILTER(B2>0,5),L*0.96,'K底'),COLORYELLOW;{KDJ底背离}
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
DRAWICON(FILTER(B3>0,5),L*0.98,10);
DRAWTEXT(FILTER(B3>0,5),L*0.98,'R底'),COLORFFFF00;{RSI底背离}

C1:=BARSLAST(REF(CROSS(DEA,DIFF),1));
D1:=REF(C,C1+1)<C AND REF(DIFF,C1+1)>DIFF AND CROSS(DEA,DIFF);
DRAWICON(FILTER(D1>0,5),H*1.07,12);
DRAWTEXT(FILTER(D1>0,5),H*1.07,'M顶'),COLOR0066FF;{MACD顶背离}
C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));
DRAWICON(FILTER(D2>0,5),H*1.05,12);
DRAWTEXT(FILTER(D2>0,5),H*1.05,'K顶'),COLORRED;{KDJ顶背离}
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
DRAWICON(FILTER(D3>0,5),H*1.03,12),;
DRAWTEXT(FILTER(D3>0,5),H*1.03,'R顶'),COLORFF00FF;{RSI顶背离}  

上一篇文章:

下一篇文章:

 




767股票学习网 | 手机版 | 微信 | 微博 | 联系站长