首页 股票学校 股票入门 选股 买入 看盘 跟庄 短线 炒股技巧 技术指标 k线图 MACD 均线 成交量 股票书籍 股票视频 网站导航

767股票学习网 > 股票学校 > 通达信公式 > 正文

通达信指标:黄金分割主图

{日:=10 10000 150;昨前:=1,100,3}
高1:=REF(HHV(H,日),昨前); 
低1:=REF(LLV(L,日),昨前);
H1:=高1-(高1-低1)*0.191; 
H2:=高1-(高1-低1)*0.382; 
H3:=高1-(高1-低1)*0.5; 
H4:=高1-(高1-低1)*0.618; 
H5:=高1-(高1-低1)*0.809;
顶:REFDATE(高1,DATE),COLORWHITE;
一:REFDATE(H1,DATE),COLORYELLOW;
二:REFDATE(H2,DATE),COLORMAGENTA;
三:REFDATE(H3,DATE),COLORLIGRAY;
四:REFDATE(H4,DATE),COLORRED;
五:REFDATE(H5,DATE),COLORWHITE;
低:REFDATE(低1,DATE),COLORYELLOW;

高手trzhrp的通达信黄金主图也很不错,转贴于此:
{黄金分割}
{N=80 1 999 , M=3 1 15} 
MA5:MA(C,5);
MA13:MA(C,13);
高:=REF(HHV(H,N),M); 
低:=REF(LLV(L,N),M);
H19:=高-(高-低)*0.191; 
H38:=高-(高-低)*0.382; 
H中:=高-(高-低)*0.5; 
H61:=高-(高-低)*0.618; 
H80:=高-(高-低)*0.809;
顶点:REFDATE(高,DATE),COLORWHITE;
%19.8:REFDATE(H19,DATE),COLORYELLOW;
%38.2:REFDATE(H38,DATE),COLORMAGENTA;
%50:REFDATE(H中,DATE),COLORRED;
%61.8:REFDATE(H61,DATE),COLORMAGENTA;
%80.9:REFDATE(H80,DATE),COLORYELLOW;
低点:REFDATE(低,DATE),COLORWHITE;
DRAWTEXT(ISLASTBAR,顶点,'顶点'),COLORWHITE;
DRAWTEXT(ISLASTBAR,%19.8,'%19.8'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,%38.2,'%38.2'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,%50,'%50'),COLORRED;
DRAWTEXT(ISLASTBAR,%61.8,'%61.8'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,%80.9,'%80.9'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,低点,'低点'),COLORWHITE;  

上一篇文章:

下一篇文章:

 




767股票学习网 | 手机版 | 微信 | 微博 | 联系站长