首页 股票学校 股票入门 选股 买入 看盘 跟庄 短线 炒股技巧 技术指标 k线图 MACD 均线 成交量 股票书籍 股票视频 网站导航

767股票学习网 > 股票学校 > 大智慧公式 > 正文

大智慧飞狐通用公式:精准黑马

精准黑马-- 主副图原码

{精准黑马,大智慧副图指标}{飞狐通用}
LS261:=EMA(CLOSE,2);
LS262:=EMA(CLOSE,150);
LS26:=LS261-LS262;
LS27:=EMA(LS26,100);
LS28:=2*(LS26-LS27);
LS29:=POW(LS28,3)*0.1+POW(LS28,1);
黑马线:IF(LS28>0.1,LS29,0)*5,COLOR0066FF,LINETHICK2;
量价线:(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100,COLOR00FF00,LINETHICK1;
TJ1:=C>MA(C,250);
TJ2:=黑马线>REF(黑马线,1);
TJ3:=量价线>REF(量价线,1);
目标:(TJ1 AND TJ2 AND TJ3)*黑马线,STICK,COLORWHITE,LINETHICK3;
启动:CROSS(黑马线,0.01)*黑马线,STICK,COLORYELLOW,LINETHICK3;
DRAWICON(启动>0,0.2,1);
TJ4:=COUNT(TJ2,2)=1;
TJ5:=COUNT(TJ3,2)=1;
回调:(TJ1 AND TJ2=0 AND TJ3=0 AND TJ4 AND TJ5)*黑马线,STICK,COLOR00FF00,
LINETHICK3;
附注:⑴{起跑指标}
Var1:=LLV(L,3)<=LLV(L,60);
Var2:=C>O and (C/O>1.03 OR C/REF(C,1)>1.03);
起:if(Var1 and Var2,量价线,0),STICK,COLORRED,linethick3;
DRAWTEXT(起>0 OR 起<0 ,0.8 , '▲'),COLORRED,LINETHICK1;
Var3:=HHV(H,3)>=HHV(H,60);
Var4:=C<O and (C/O<0.97 OR C/REF(C,1)<0.97);
跑:if(Var3 and Var4,黑马线,0),STICK,COLORFF6600,linethick3;
DRAWICON(跑>0,0.2,2);
{精准黑马Z----一品茶缘编写,大智慧主图指标}{飞狐通用}
MA5:MA(C,5),COLORWHITE,LINETHICK2;
MA30:MA(C,30),COLORYELLOW,LINETHICK2;
MA250:MA(C,250),COLORRED;
黄启白买绿回:0,COLOR00FF00;{飞狐版本请将本句加大括号,或删除}
LS261:=EMA(CLOSE,2);
LS262:=EMA(CLOSE,150);
LS26:=LS261-LS262;
LS27:=EMA(LS26,100);
LS28:=2*(LS26-LS27);
LS29:=POW(LS28,3)*0.1+POW(LS28,1);
黑马线:=IF(LS28>0.1,LS29,0)*5,COLOR0066FF,LINETHICK2;
量价线:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100,COLOR00FF00,LINETHICK1;
TJ1:=C>MA(C,250);
TJ2:=黑马线>REF(黑马线,1);
TJ3:=量价线>REF(量价线,1);
启动:=CROSS(黑马线,0.01)*黑马线,STICK,COLORYELLOW,LINETHICK2;
目标:=(TJ1 AND TJ2 AND TJ3)*黑马线,STICK,COLORWHITE,LINETHICK2;
TJ4:=COUNT(TJ2,2)=1;
TJ5:=COUNT(TJ3,2)=1;
回调:=(TJ1 AND TJ2=0 AND TJ3=0 AND TJ4 AND TJ5)*黑马线,STICK,
COLOR00FF00,LINETHICK3;
附注:⑵{起跑指标}
Var1:=LLV(L,3)<=LLV(L,60);
Var2:=C>O and (C/O>1.03 OR C/REF(C,1)>1.03);
起:=if(Var1 and Var2,量价线,0),STICK,COLORRED,linethick3;
Var3:=HHV(H,3)>=HHV(H,60);
Var4:=C<O and (C/O<0.97 OR C/REF(C,1)<0.97);
跑:=if(Var3 and Var4,黑马线,0),STICK,COLORFF6600,linethick3;
DRAWICON(跑>0,0.2,2);
{以下设置主图显示方式:}
DRAWICON(启动>0,L-0.02,1);
STICKLINE(启动>0,h,l,0,1),colorYELLOW,linethick2;
STICKLINE(启动>0,o,c,4,1),colorYELLOW,linethick2;
DRAWTEXT(目标>0 ,MA30-0.02 , '○'),colorWHITE,LINETHICK1;
DRAWTEXT(回调>0 ,L*0.99 , '◆'),COLOR00FF00,LINETHICK1;
STICKLINE(回调>0 ,h,l,0,1),COLOR00FF00,linethick2;
STICKLINE(回调>0 ,o,c,4,1),COLOR00FF00,linethick2;
DRAWTEXT(起>0 OR 起<0 ,L-0.02 , '▲'),COLORRED,LINETHICK1;
DRAWICON(跑>0,L-0.05,2);
附:{黑马跟踪}指标原码:
{黑马跟踪----创幻贵宾沉思思编写,一品优化版,各种软件通用}
n1:=barslast(cross(C,MA(C,5)));
n2:=barslast(cross(MA(c,5),c));
黑马:if(n1<n2,n1+1,0),COLOR00FFFF,linethick2;
跟踪:if(n2<n1,n2+1,0),COLORFF00FF,linethick2;
涨:(c-ref(c,黑马))/ref(c,黑马)*100,COLOR0000FF;
STICKLINE(涨>黑马,黑马,涨,1,1),COLORFFFFFF;
跌:(c-ref(c,跟踪))/ref(c,跟踪)*100,COLORFFFF00;
STICKLINE(ABS(跌)>ABS(跟踪),-跟踪,跌,1,1),COLORFF6600;
ZF:(C-REF(C,1))/REF(C,1)*100,COLOR00FF00,POINTDOT,LINETHICK0;
LXSZ:=黑马>=2 AND 黑马<=4 AND COUNT(ZF>0,3)>=2;
XGL:=(C-MA(C,5))/MA(C,5)*100<2 OR (L-MA(C,5))/MA(C,5)*100<2 AND ZF<3;
骑马:(REF(LXSZ,1) AND (ZF<1 OR XGL))*黑马,COLOR00FF00,LINETHICK2;
登高:黑马>5 AND ZF>0 AND COUNT(ZF>0,3)>=2 AND COUNT(涨>18,2),POINTDOT,
COLORFFFFFF,LINETHICK2;
下马:(ZF<0 AND REF(登高,1))*涨,COLORFFFF00,LINETHICK2;
STICKLINE(登高=1,18,涨,4,0),COLORFFFFFF;
STICKLINE(黑马=1,0,5,4,0),COLOR00FFFF;
STICKLINE(跟踪=1,0,5,4,1),COLOR00FF00;
if(n2<n1,-(n2+1),0),COLORFFFFFF,linethick1;  

上一篇文章:

下一篇文章:

 




767股票学习网 | 手机版 | 微信 | 微博 | 联系站长