首页 股票学校 股票入门 选股 买入 看盘 跟庄 短线 炒股技巧 技术指标 k线图 MACD 均线 成交量 股票书籍 股票视频 网站导航

767股票学习网 > 股票学校 > 大智慧公式 > 正文

大智慧、飞狐公式:均线拐点

【均线拐点】主副图原码:

指标编写思路:(1、中线多头排列,安全操作;2、短线多头排列、或近期曾经多头排列;3、短期均线处于粘合状态(粘合间距默认为N--3%,龙头股可以适当调大);
4、短期均线曾经回调至粘合状态;5、当5日均线重新拐头向上时,即为新的波段买点。指标测试成功率:2006年5天3%、10天5%、20天10%均在70%左右,不算高;但是相对安全,大波段基本能够抓住。)
{均线拐点,大智慧副图指标/飞狐通用}
{N:1,10,3;}
MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
MA60:=MA(C,60);
MA120:=MA(C,120);
短线多头:=MA5>MA10 AND MA10>MA20 AND MA20>MA30;
中线多头:=MA30>MA120 AND MA60>MA120;
均线粘合:=(HHV(MA5,HHV(MA10,MA20))/LLV(MA5,LLV(MA10,MA20))-1)*100<=N;
均线拐点:=COUNT(短线多头,10) AND COUNT(MA5<REF(MA5,1),3) AND MA5>REF(MA5,1);
XG:=中线多头 AND 均线粘合 AND 均线拐点 AND C>REF(C,1);
选股:XG AND NOT(REF(XG,1)),COLORYELLOW,linethick2;
均线粘合2:
=(MAX(MA5,MAX(MA10,MA20))/MIN(MA5,MIN(MA10,MA20))-1)*100<=N;
XG2:=中线多头 AND 均线粘合2 AND 均线拐点 AND C>REF(C,1);
选股2:(XG2 AND NOT(REF(XG2,1)))*0.5,COLORWHITE,linethick2;
{均线拐点Z----一品茶缘编写,大智慧主图指标/飞狐通用}
{N:1,10,3;}
MA5:MA(C,5);
MA10:=MA(C,10);
MA20:MA(C,20);
MA30:MA(C,30);
MA60:MA(C,60);
MA120:=MA(C,120);
短线多头:=MA5>MA10 AND MA10>MA20 AND MA20>MA30;
中线多头:=MA30>MA120 AND MA60>MA120;
均线粘合:=(HHV(MA5,HHV(MA10,MA20))/LLV(MA5,LLV(MA10,MA20))-1)*100<=N;
均线拐点:=COUNT(短线多头,10) AND COUNT(MA5<REF(MA5,1),3) AND MA5>REF(MA5,1);
XG:=中线多头 AND 均线粘合 AND 均线拐点 AND C>REF(C,1);
选股:=XG AND NOT(REF(XG,1));
均线粘合2:
=(MAX(MA5,MAX(MA10,MA20))/MIN(MA5,MIN(MA10,MA20))-1)*100<=N;
XG2:=中线多头 AND 均线粘合2 AND 均线拐点 AND C>REF(C,1);
选股2:=XG2 AND NOT(REF(XG2,1)),COLORWHITE,linethick2;
{以下设置主图显示方式:}
STICKLINE(选股,h,l,0,1),COLORYELLOW,linethick2;
STICKLINE(选股,o,c,4,1),COLORYELLOW,linethick2;
DRAWTEXT(选股,L-0.1, '买'),COLORYELLOW;
STICKLINE(选股2,h,l,0,1),COLORWHITE,linethick2;
STICKLINE(选股2,o,c,4,1),COLORWHITE,linethick2;
DRAWTEXT(选股2,L-0.15, '买2'),COLORWHITE;  

上一篇文章:

下一篇文章:

 




767股票学习网 | 手机版 | 微信 | 微博 | 联系站长