首页 股票学校 股票入门 选股 买入 看盘 跟庄 短线 炒股技巧 技术指标 k线图 MACD 均线 成交量 股票书籍 股票视频 网站导航

767股票学习网 > 股票学校 > 通达信公式 > 正文

通达信版副图本公式:obv.macd

{通达信版副图本公式:obv.macd}
OBV:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0))/25000,0),1);
OBVE:=EMA(OBV,3);
DIFF : EMA(OBVE,12) - EMA(OBVE,26),LINETHICK2;
BBDIFF:=DIFF-REF(DIFF,1);
DEA : EMA(DIFF,9),LINETHICK2;
BBDEA:=DEA-REF(DEA,1);
MACD : 2*(DIFF-DEA), COLORSTICK;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2.5,0),COLORGREEN;
STICKLINE(MACD<REF(MACD,1)AND MACD<0,0,MACD,3,1),COLORFFCC33;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,3,1),COLOR0099FF;
STICKLINE(MACD>REF(MACD,1)AND MACD>0,0,MACD,3,1),COLORYELLOW;
IF(BBDEA>0,DEA,DRAWNULL),COLOR9966CC,LINETHICK2;
IF(BBDEA<0,DEA,DRAWNULL),COLOR00FF33,LINETHICK2;
IF(BBDIFF>0,DIFF,DRAWNULL),COLORRED,LINETHICK2;
IF(BBDIFF<0,DIFF,DRAWNULL),COLORCYAN,LINETHICK2;
--------------------------------------------
{STICKLINE(C>=O,C,O,3,0),COLORGREEN;
STICKLINE(C>=O,H,C,3,1),COLORRED;
STICKLINE(C>=O,H,C,3,1),COLORRED;
STICKLINE(C>=O,O,L,3,1),COLORGREEN;
STICKLINE(C<O,C,O,3,1),COLORGREEN;
STICKLINE(C<O,C,O,3,1),COLORGREEN;
STICKLINE(C<O,H,O,3,1),COLORGREEN;
STICKLINE(C<O,C,L,3,1),COLORGREEN;}

VAR3:=MA(C,8)*1.01;
VAR4:=MA(O,13)*1.01;
VAR5:=(MA(HIGH,5)+MA(LOW,5)+MA(CLOSE,5)+MA(OPEN,5)+HIGH+LOW+CLOSE+OPEN)/8;
VAR6:=IF(VAR4>VAR5,VAR4,VAR5);
VAR7:=IF(VAR4<VAR5,VAR4,VAR5);
VAR8:=3/100;
STICKLINE(VAR3>VAR4,VAR3,VAR4,4,1),COLORYELLOW;
STICKLINE(VAR3<=VAR4,VAR3,VAR4,4,1),COLORLIBLUE;
STICKLINE(VAR4>VAR5,VAR4,VAR5,1,0),COLORGREEN;
STICKLINE(VAR4=VAR5,VAR4,VAR5,1,1),COLORRED;
抢1:MA(VAR7,5)*(1-VAR8),COLORGREEN;
防1:MA(VAR6,5)*(1+VAR8),COLORWHITE;
抢2:EMA(VAR6,3)*(1-VAR8),COLORRED;
防2:EMA(VAR7,3)*(1+VAR8),COLORYELLOW;

上一篇文章:

下一篇文章:

 




767股票学习网 | 手机版 | 微信 | 微博 | 联系站长